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1Chapter 1
Getting Started

These  tutorials  assume that  you are  new to  Mecway  and  indeed  may  be  new to  finite  element
analysis. Here you will find step by step instructions to get you started using the program. Once you
have learned the basic concepts and operations, you can find more comprehensive information in the
companion ‘Manual’.

1.1 Quick Start
This is a very simple tutorial showing you how to create a working model from scratch. You can skip
this if you prefer a more in depth introduction from the other tutorials.

Step 1

Change to Select faces mode.

Step 2

Click the Quick cube button  to create a hexahedron element.

Step 3

Right click the right-most face and click
Loads & constraints then  New fixed
support.  Click  OK in  the  box  that
appears.

Step 4

Drag with the middle mouse button to rotate the model so the opposite face is towards you. If you
don't have a middle mouse button, use the Rotate tool button  and the left mouse button.
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Step 5

Right  click  the opposite face and click  Loads &
constraints then New pressure. Enter the value 5
and press OK.

Step 6

Right click the Default component in the outline tree and click Assign new
material.  Choose  Isotropic  and  enter  a  Young's  modulus of  50000.
Press OK.

Step 7

Press solve. 

Step 8

Click the von Mises stress field variable in the outline tree.
The color key shows a 5 Pa uniform stress due to the
pressure load.

1.2 Basic Operations in the Graphics Area
Because the graphics is so much a part of Mecway, let us look first at a data file which displays a
model and its solution.
Step 1

File → Open, Basic_graphics_tutorial.liml in the tutorials folder where Mecway has been installed.
This is a contrived example merely to show the graphics features.
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There are three parts to the screen
 the toolbars at the top, arranged into model-building tools and the graphics display options.
 the model structure and solution displayed in an outline tree in the left panel
 a graphics area which displays the mesh

This sample is a beam with a T-shaped end and has already been solved. One end is totally fixed, as
if built into a wall. At the free end, a downwards force is applied at 4 faces. The self-weight of the beam
has been neglected.

Step 2

 Toggle the display of element surfaces.
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 Toggle element edge display.

Step 3

Select nodes

Turn off the display of elements surfaces and
turn on element edges. Drag over the model
to select nodes, including internal nodes.

Click in an open space to deselect the nodes.
Then click  a  node to  select  it.  Hold  the  Ctrl key
down and  click  a  couple  of  nodes  to  add  to  the
selection set. If a node is already selected and it's
clicked on while holding 
down the Ctrl key, it becomes deselected.

Drag a node to a new location. Repeat the action on
another node, but this time hold down the Shift key.
You'll notice that the node is fixed and cannot be
dragged.

Edit → Undo or Ctrl + Z to return the displaced node.

Click in an open space to deselect the nodes. 

Select faces . Drag over the model to see that 
only surfaces are selected.

Click in an open space to deselect the surfaces.
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Select elements . Drag to see that only elements have been selected.

The Ctrl key has the same effect while selecting faces or elements as it does with selecting nodes.

Step 4

The display  of  loads and constraints  can be
toggled off or on.

Step 5

Click the Z arrowhead of the triad at the bottom right corner of the graphics area to view
the model parallel to the screen.

Left  or  right  clicking  the  arrowheads
will  display  the different  views  of  the
model parallel to the screen.

Click the blue dot to return to an isometric view.

Step 6

To rotate the view, drag with the middle mouse button (or wheel).
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To see a small feature more clearly, zoom into that area by placing the mouse over that area (no
clicking required) and rotating the mouse wheel for a larger display of the small feature. Rotating the
mouse wheel the other way will make the model's display become smaller.

If the model's display seems to be half out of the graphics area, you need to pan the model back into
view. Drag it using the right mouse button.

If the model does not fully appear in the graphics area after you have used the zoom, rotate or pan,
use the fit to window tool-button  

Step 7

Use the tape measure tool-button to  check the lengths.  Click  a  node but  continue keeping  the
mouse button pressed and move the cursor across to another node. Mecway will give a readout
of that distance.

Step 8

Tools → Volume will give volume of the entire mesh. This tool can be used to obtain the volume of a
selected part of the mesh. The selection can be element nodes, faces or elements.

Similarly the Tool → Surface area will give the area of the selected faces. The selections can only be
element faces.

1.3 Solution
Step 1

This tutorial uses the same file as the previous tutorial. So if it is not already open in Mecway, use the
File → Open, Basic_graphics_tutorial.liml in the tutorials folder where Mecway has been installed.

In the solution section of the outline tree click on displacement → magnitude. The graphics display
will update to show the results of the solved model. The units used in the legend on the display scale
can be changed by clicking on them.

Step 2

Click the Deformed view tool-button to visualize an exaggerated displacement of the structure.

Click  the Undeformed  shape to  superimpose  an  outline  of  the  undeformed  shape  onto  the
deformed mesh.
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Step 3

Right click  Solution in the outline tree and choose  new stress and strain → stress to add the 6
stress components to the solution.

Step 4

Click the table tool-button to display the displacements, rotations and stresses at each node in
spreadsheet-style cells which you can then copy and paste into your own spreadsheet.

Step 5

Use the animation tool-button to animate the deflection.  Smooth deformation between the two
extremes of movement is simulated. You can choose the scale factor. This tool is especially useful for
visualizing solutions in vibration analysis.

Step 6

This slider can be used to cut-away the model to look inside it.  You will  need to
rotate the model suitably so that the cut occurs where you want it. Don't forget to

return to its leftmost position before doing any editing of the mesh.

To return to the model that does not display the results, click any of the items in the outline tree that is
not below Solution. 

Now that you have some experience in manipulating the graphics of the model, it’s time to learn how
to create them from scratch. The next section will walk you through the case we have just studied.
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1.4 Manual Meshing

Always begin a manual mesh by creating a coarse mesh; it can always be refined later. A coarse mesh
simply means larger and fewer elements, and a refined mesh means smaller and more elements.
Creating a coarse mesh requires less labor and, if things go wrong, it will be less frustrating. 

Just  as  in  the  real  world  where  everything  has  three  dimensions  (length,  width,  height),  the
geometrical properties of finite elements are also three dimensional in nature. Some elements will
appear on the screen as being clearly three dimensional elements, while others will appear on the
screen as flat and two dimensional. Nevertheless, the elements that appear flat and two dimensional
do actually have the third dimension, of thickness.

Elements that appear three dimensional on the screen will usually be created from a two dimensional
flat shape, so modeling typically starts with what appears on the screen as a flat two dimensional
mesh. This initial 2D mesh can be created either by a combination of nodes and elements or by using
ready-made template patterns. Editing tools are available for modifying the two dimensional mesh as
you create and form it. Once the coarse mesh is complete, whether it be two dimensional or three
dimensional in appearance, it will need to be refined before running the solver.

Here is a tutorial to illustrate how the manual meshing tools work together to create the model used in
the introductory chapter. We will recreate the T-shaped thick beam used in section 1.2 to illustrate
Mecway's graphics tools.  At the end you may wish to use some of the skills you have learned to
modify the length and thickness of the beam to make it more realistic.

Step 1

The analysis type should be Static 3D. If it's not, right click the item,  then select
Analysis settings to change the analysis type.

Use the Mesh tools → Create → Node... or and enter the following coordinates.
X 0
Y 0
Z 0
Leave the units as meters (m).

Click the Add button. Repeat for the following coordinates, then click Close.
11,0,0
11,1,0
0,1,0

Click the Z arrowhead to view the XY plane parallel to the screen. 

To view the entire model, use fit to window 
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Step 2

Mesh  tools  →  Create  →  Element... Select  and click the four  nodes then click
Close. The order of the clicked nodes will affect the orientation of the mesh refinement that will be
done in the next step. In this tutorial, the element is formed using the node order 1-2-3-4.

Step 3

Mesh tools → Refine → Custom...
Number of subdivisions
R 11
S 4
T 1
Click OK

Step 4

Activate select faces

Drag to select the entire mesh.

Mesh tools → Extrude... 
Direction +Z
Thickness 2, units m
Number of subdivisions 2

Click the blue dot to view an isometric display of the model.
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Click in the open space of the graphics area to deselect the elements.

Step 5

Activate select faces

To improve clarity use the show element surfaces tool-button  to hide the internal elements.

Select  these two faces by clicking one face then holding the Ctrl key while
clicking the second face.

The  Ctrl key can be used while selecting items. It works by adding the new items to the currently
selected items, and if the clicked item is already selected it will become deselected.

Mesh tools → Extrude... 
Direction +Normal
Thickness 3, unit ft
Number of subdivisions 1

Notice that  you can use a mixture of  different
units for different quantities.

Drag with the middle mouse button or wheel to rotate the
view of  the  model  or  use  this   if  you  don't  have  a
middle button.

Activate select faces

Select these two faces.

Mesh tools → Extrude... 
Direction +Normal
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Thickness 3, unit ft
Number of subdivisions 1

Step 6

Click in an open space of the graphics area to deselect the model.

Activate select nodes to see that these are 8 node hexahedrons. 

Change  these  8  node  hexahedrons  into  the  more  accurate  20  node
hexahedrons using  Mesh tools → Change element shape...  select  hex20
and click OK to accept. The hex8 elements give a linear approximation to the
displacement field, whilst the hex20 elements give a quadratic approximation.

Step 7

Right click,  Assign new material

Mechanical tab
Isotropic select
Young's modulus 200, unit GPa
Poisson's ratio 0.3

A material is now associated with the elements.

Step 8

In order for a part to develop stresses, all rigid body motion must be resisted. The left face of this 
model will be constrained.

Activate select faces
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Select these faces.  Hold the Ctrl key down while clicking to add the faces so that the faces already
selected don't become deselected.

Right click, select New fixed support accept the defaults and click OK

Step 9

Select these faces. 

Right click, select New force 
Y -3500, unit lbf

The 3500 pound force will  be distributed uniformly
over the selected faces. So each equally-sized face
will have a load of 3500 lbf / 4 or 875 lbf.
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Step 10

Before you run the solver, check down the outline tree to make sure there are no warnings in red.

Click to solve the model. 

The results are listed in the outline tree below Solution. 

You may now wish to explore Mecway's mesh-modifying tools, for instance by scaling the length, width
and thickness of the beam using Mesh tools → Scale... or changing the applied load and/or elastic
constants by right clicking to edit the appropriate item in the outline tree.

The next chapter is a step-by-step walk through for some of the various analysis types that can be
modeled in Mecway.
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2Chapter 2
Analysis Types

While the typical  user does not  need an in-depth study of  the mathematics behind finite element
analysis, you do need to understand the behavior of elements in order to represent a given physical
problem correctly.

Finite element analysis is not like CAD (computer aided design) software where you simply create a
geometry and take a print-out. Instead, it follows the law of 'Garbage in, Garbage out'. Your choice of
element type, mesh layout and constraints will strongly affect the accuracy of the solution.

We recommend to beginners that you confine your models to text-book problems with known solutions
rather  than attempting real  world problems with unverifiable solutions.  When you get  to the point
where you're solving real world problems, never accept the results at face value. Rather, validate them
by comparing the results to hand calculations,  experimental  observations or  knowledge from past
experience.

This chapter contains tutorials to initiate you into using Mecway's basic analysis capabilities. Some of
the more specific features like cyclic symmetry and constraint equations are described in Chapter 3 -
Operations.

Not all types of elements can be used for all types of analysis. The Manual lists
the elements that are available for use in each type of analysis. When creating
elements,  if  you see an N/A ('not  applicable')  next  to  the type of  element,  it
means it can't be used to solve that type of analysis. However, you can use non-
applicable elements as construction tools provided you change them using Mesh
tools → Change element shape... , or delete them before solving.

The outline tree presents all the information you need about your model and
allows you to perform various actions on the model itself. You will always
begin at the top, changing the analysis type if you do not want the default,
3D static analysis. 

Items that appear in red indicate missing or erroneous information, so right
click them for a What's wrong? clue. 

The constraints and loads that you apply will  be listed in the  Loads & Constraints section. After
solving the model the field values will be listed below Solution.
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2.1 Static Analysis of a Pressurized Cylinder
A cylinder of 2m radius, 10m length, 0.2m thickness, Young's modulus  200 GPa and Poisson ratio
0.285 will be analyzed to determine its hoop stress caused by an internal pressure of 100N/m2. 

From shell theory, the circumferential or hoop stress for a thin cylinder of constant radius and uniform
internal pressure is given by :

σ = (pressure × radius) / thickness

σ = (100 × 2) / 0.2

σ = 1000 N/m2

Step 1

Check that the default analysis type is Static 3D.

Step 2

Mesh tools  → Create  → Create  curve  generator...
select 
X1 2 m
Y1 0
Z1 0
X2 2 m
Y2 0
Z2 10 m
Number of nodes 12

Use the Fit to window  to display the elements.

Step 3

Due  to  the  axial  symmetry,  only  one  quadrant  will  be
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modeled. 

Activate select faces  and drag to select all the elements.

Mesh tools → Revolve...
Axis of revolution +Z
Angle 90 °
Number of subdivisions 8

Step 4

Right click,  Assign new material
Geometric tab 
select Shell/membrane
Thickness 0.2 m

Mechanical tab
select Isotropic
Young's modulus 200E9 Pa
Poisson's ratio 0.285

Step 5

Right click the X arrowhead to view the YZ plane parallel to the screen. 

Activate select faces, activate show element surfaces,  and activate show shell thickness 

Because of the mirror symmetry only one quadrant of the cylinder has been modeled. At the planes of
mirror symmetry, the nodes must be constrained so that they do not move out of the plane. Also, no
bending must occur in that plane of symmetry.

To enforce mirror symmetry at the edge in the YZ
plane, drag to select the edge of the shell.
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Right click, New displacement and select the X option.

Right click, New node rotation and select the Z option.

Right click the Y arrowhead to view the ZX plane parallel to the screen.

To enforce mirror symmetry at the edge in the ZX plane, drag to select the thickness
of the shell.

Right click, New displacement and select the Y option.

Right click, New node rotation and select the Z option.

Right click the Z arrowhead  to view the XY plane parallel to the screen.

To eliminate rigid body translation motion along the Z axis drag to select the
shell thickness in the XY plane.

Right click, New displacement and select the Z option.
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Step 6

Disable  Show  shell  thickness  then  drag  to
select the entire external surface.

Right click, New pressure
-100 Pa

Step 7

Click to solve the model. 

The results are listed in the outline tree below Solution. Click von Mises stress. to view the hoop 
stress.

The first thing to check is the deformation. Errors in the applied constraints or loads can show up in 
the deformation shape.

Click the Z arrowhead  to view the XY plane parallel to the screen. 

Click the Deformed view tool-button .

Click the Undeformed shape tool-button  to superimpose the undeformed geometry onto the 
deformed geometry.

Observe  that  the  nodes  in  the  YZ  and  ZX  plane
remain in these planes and no bending has occurred,
this indicates that the constraints applied to enforce
symmetry  are  working.  The  fact  the  deformation
expands  outward  radially  indicates  that  the  internal
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pressure has been correctly applied.

The computed hoop stress is only 0.48% different 
from the hand calculations. This is close enough 
not to need further mesh refinement.
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2.2 Thermal Analysis of a Plate being Cooled
A plate of cross-section thickness 0.1m at an initial temperature of 250°C is suddenly immersed in an
oil bath of temperature 50°C. The material has a thermal conductivity of 204W/m/°C, heat transfer
coefficient  of  80W/m2/°C,  density  2707 kg/m3  and a specific  heat  of  896 J/kg/°C. It  is  required to
determine the time taken for the slab to cool to a temperature of 200*C.

For Biot numbers less than 0.1, the temperature anywhere in the cross-section will be the same with
time. A quick calculation shows that this is true.

Bi = hL/k = (80)(0.1)/(204) = 0.0392

The 4 node quadrilateral element interpolates temperature linearly, and is able to represent unsteady
states of heat transfer so this element will be selected for the model.

We need to have a rough estimate of the time required to reach a temperature of 200*C. In this case,
from classical heat transfer theory the following lumped analysis heat transfer formula can be used.

(T(t)-Ta)/(To-Ta) = e-(mt)

Ta = temperature of oil bath

To = initial temperature

where m =  h/ ρ Cp(L/2)

h = heat transfer coefficient

ρ = density

Cp = specific heat

L = thickness

m = 80/[(2707)(896)(0.1/2)]

m = 1/1515.92 s-1

(200 - 50) / (250 - 50) = e(-t/1515.92)

t = ln (4) X 1515.92

t = 436 s

Step 1

Right click, Edit. Select Thermal Transient
Time period 450 s
Time step 1 s

A slider is displayed to show the duration of the analysis, which in this case is 450 seconds. It will be
utilized when viewing the results.
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Step 2

Click the Z arrowhead to view the XY plane parallel to the screen. 

Mesh tools → Create → Node... 

X 0
Y 0
Z 0

The node appears as a red dot at the origin.

If you don't see the node make sure you've activated the node select mode 

Add more nodes using the following coordinates with units of m:
(0.1,0,0)
(0.1,0.2,0)
(0,0.2,0)

Use the Fit to window  to display the nodes.

Step 3

Mesh tools → Create → Element... Select and click the four nodes.

The order of nodes will affect the way the element gets subdivided in a following step.
So, to keep the order the same, start at the lower left corner and go counter-
clockwise. 
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Step 4

Right click, select Assign new material
Geometric tab
Shell/membrane select
Thickness 1 m

Density tab
Density 2707 kg/m3

Thermal tab
Isotropic select
Thermal conductivity 204 W/m/K
Specific heat 896 J/kg/K

Step 5

Activate select faces

Select the element. 

Mesh tools → Refine → Custom...
R 4
S 8

Step 6

Convective heat transfer takes place along the surface of the entire plate. For the FE
model, this will be the left and right edges. Click and drag the mouse over the left edge so
that the edge faces become selected. Hold the Ctrl key down and repeat it for the right
edge.
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Right click then select New convection

Ambient temperature 50 °C. Note that the unit is not K.
Heat transfer coefficient 80 W/m2/K

Step 7

Drag a rectangle to select the entire mesh.

Right click and select New temperature. Ensure °C is selected then type 250 in the
text-box.

Step 8

Click to solve the model. The results are listed in the outline tree below Solution. 

Click 

Drag the slider to view the temperature changes with time.
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If you click a node the temperature profile of that node will be displayed in the timeline.

From the results we see that it takes about
440  seconds  to  reach  the  temperature  of
200°C.

For transient thermal models if your results show a strange oscillation of temperatures every other
time-step, use a smaller time-step value and refine the mesh further.

2.3 Heat Flow Through a Solid Part
Step 1

Open TransientThermalTutorial.liml from the tutorials folder where
Mecway has been installed. 

Step 2

Double click Analysis 
General tab
Time period 300 s
Time step 10 s
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Step 3

Right click Meshed_Geometry and select Assign new material
Density tab
Density 2700 kg/m3

Thermal tab
Isotropic
Thermal conductivity 200 W/m/K
Specific heat 890 J/kg/K

Step 4

Right click the arrowhead of the Y-axis to display the model parallel
to the screen.

Activate the Select nodes mode.

Drag to select the entire mesh.

Edit → Circle selection

Hold  the  Ctrl key  down  and  drag  to  deselect  the  nodes  of  the  inner
diameter.

Right click Initial Conditions and select New temperature
Apply to <848 Selected nodes>

22 °C

This sets the selected nodes to an initial temperature of 22  °C. The reason the nodes of the inner
diameter  were deselected is  because a  constant  temperature is  going to be applied  to the inner
diameter. It's not physically possible for a node to be both at an initial temperature of 22  °C  and a
different constant temperature at the same time.
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Step 5

We will now fix the temperature at the internal diameter to 120 for the entire analysis.

Right click Surface11 and select New loads & constraints
→ New temperature
Apply to Surface 11
Formula 120 °C

Repeat for Surface12 

Step 6

Right click Surface7 
New loads & constraints → New Convection
Apply to Surface 7
Ambient temperature 22 °C
Heat transfer coefficient 40 W/m2/K

Step 7

Solve

Select any of the results listed below solution.

Drag the slider on the timeline to display the results at the various time steps. Select a node to display 
a graph of its temperature.

2.4 Thermal Stress
Step 1

Start a new model. File → New

Double click Analysis in the outline tree and select Thermal Steady State then press OK.

Step 2

Create a new hex8 element by clicking the Quick cube tool-button. 

Step 3

Activate select faces 
Click anywhere in the graphics area to
clear the selection.
Right click any face and select Loads &
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constraints → New temperature
Enter the value 100. This constrains the temperature of that face to 100°C.

Step 4

Right  click  another  face  and  select  Loads  &  constraints  →  New
convection

Ambient temperature 20

Heat transfer coefficient 400

Step 5

Right  click  the  component  Default  <1  elements> in  the  outline  tree  and  choose  Assign  new
material.

Select Isotropic and enter a Thermal conductivity of 40. This is 40W/(m.K).

Step 6

Solve.

Click Temperature under the Solution branch of the outline tree.

Notice that some nodes have an unrealistic temperature lower than
the 20°C ambient. This is because of the extremely coarse mesh.
In  a  practical  problem,  you  would  refine  the  mesh  to  improve
accuracy.

Step 7

Double click Analysis. Select Static 3D

Step 8

Right click Loads & constraints and select Transfer temperatures from 
solution

Step 9

Right click Loads & constraints and select New thermal stress
Reference temperature 20
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The reference temperature is the initial temperature of the nodes that are now at the temperatures 
which were transferred from the thermal analysis solution.

Step 10

Right click Material and select Edit

Mechanical tab
Isotropic
Young's modulus 200E09
Thermal expansion coefficient 11E-06

Density tab
Density 7800

Step 11

Right click any face and choose Loads & constraints → New fixed 
support

Step 12

Solve

The solution now shows the cube deformed by thermal expansion.

2.5 Free Vibration of a Cantilever Beam

A cantilever beam of length 1.2m, cross-section 0.2m × 0.05m, Young's modulus 200×109 Pa, Poisson
ratio  0.3  and  density  7860  kg/m3.  The  lowest  natural  frequency  of  this  beam  is  required  to  be
determined.

For thin beams, the following analytical equation is used to calculate the first natural frequency :

f = (3.52/2π)[(k / 3 × M)]1/2

f = frequency

M = mass

M = density × volume

M = 7860 × 1.2 × 0.05 × 0.2

M = 94.32 kg

k = spring stiffness

k = 3×E×I / L3
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I = moment of inertia of the cross-section.

E = Young's modulus

L = beam length

I = (1/12)(bh3)

I = (1/12) (0.2 × 0.053)

I = 2.083×10-6 m4

k = (3 × 200×109 × 2.083×10-6) / 1.23

k = 723.379×103 N/m

f = (3.52/2 × 3.14) [(723.379×103/ 3 × 94.32)]1/2

f = 28.32 Hz

Step 1

Right click, Edit, then select Modal Vibration 2D.

Number of modes 3

Step 2

Mesh tools → Create → Node... 
X 0
Y 0
Z 0

The node appears as a red dot at the origin.

If you don't see the node make sure you've in the node select mode

Click the Z arrowhead to view the XY plane parallel to the screen. 
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Add more nodes using the following coordinates, all with units of m.
(1.2,0,0)
(1.2,0.05,0)
(0,0.05,0)

Use the Fit to window to display the nodes.

Step 3

Mesh tools → Create → Element... Select and click  the four  nodes.  The order  of
the clicked nodes will affect the orientation of the mesh refinement that will be done in the next step. In
this tutorial the element is formed using the node order 1,2,3,4.

Step 4

Right click,  Assign new material
Geometric tab select Shell/membrane
Thickness 0.2 m

Mechanical tab
Isotropic select
Young's modulus 200 GPa
Poisson's ratio 0.3

Density tab
Density 7860 kg/m3

Step 5

Mesh tools → Refine → Custom...
Number of subdivisions
R 16
S 1
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Step 6

Elements with mid-side nodes (quadratic) are more  accurate in bending problems. The four node
quadrilaterals will be changed into eight node quadrilaterals using  Mesh tools → Change element
shape..., select quad8 

Step 7

Activate select faces 

Click to select the left edge face.

Right click then select New fixed support

Step 8

Click to solve the model. 

The results are listed in the outline tree below Solution. Click

Click the animation tool-button to view the mode shape. For this problem, the lowest mode shape 
is expected to vibrate back and forth in bending.

The displacement  values of  a modal  analysis  are only  meaningful
relative to each other. The magnitude of the displacement of a real
structure  depends  on  load  history  and  damping  which  are  not
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modeled by modal vibration analysis.

The frequency for the lowest mode matches the hand calculation result of 28.32 Hz

2.6 Dynamic Response of a Crane Frame

A dynamic response analysis is difficult to estimate values for by simple hand calculations. This tutorial
will simply illustrate the dynamic response analysis work-flow of a crane's truss framework.

Step 1

Right click, Edit. Select Dynamic Response 2D
Time period 0.5 s
Time step 0.005 s

Step 2

Mesh tools → Create → Curve generator... select 
X1 0
Y1 0
Z1 0
X2 20, unit m
Y2 0
Z2 0
Number of nodes 5

Click OK twice then click the Z arrowhead to view the XY plane parallel to the screen. 

Use the Fit to window  to display the whole mesh.

34



Activate select elements

Drag  to  select  all  the  elements.  Right  click  on  the  selected
elements  and  select  Element  properties.  Select  the  check-box
next to  Truss to convert these elements from beam elements to
truss.

Step 3

With all elements still selected
Mesh tools → Move/copy...
Y 5, unit m
Copy select
Click Apply then Close.

Step 4
Mesh tools → Create → Element...  Select  line2 and click the
nodes to form the pattern shown.

Step 5

Right click,  Assign new material
Geometric tab
General section select
Cross-sectional area 0.0225, unit m2

Mechanical tab
Isotropic select
Young's modulus 20E09, unit Pa
Poisson's ratio 0.3

Density tab
Density 7860, unit kg/m3

Click OK.

Step 6

Activate select nodes

Select  these two nodes.  Hold the  Ctrl key down while  selecting the
second node so as not to deselect the first node. 
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Right click then select New displacement, select Y and click OK.

Select this node alone.

 
Right  click then select  New displacement, select X and click OK.

Step 7

Select this node. 

Right click then select New force
Y
Table select

0.09 0
0.1 -1

Choose units s and N then click OK.

Step 10

Click to solve the model. 

The results are listed in the outline tree below Solution. Click one of them to display it.

Click the play/pause button in the timeline to view the dynamic response of the structure. Click 
Solution → Deformed view to deform the structure while it's animated.
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2.7 Dynamic Response of a Solid Part
Step 1

Open DynamicResponseTutorial.liml from the tutorials folder where Mecway
has been installed. 

Step 2

Double click Analysis 
Time period 0.003 s
Time step 0.0004 s

Step 3

Activate the Select nodes mode and select this node. 

An applied force will ramp up linearly from 0 to a maximum 500 N then down to 0. At each time step
Mecway will determine the force by interpolating between the specified values.

Right click Loads & Constraints and select New force
Apply to <Selected nodes>
X
Table 0 0

0.0015 500
0.003 0
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Step 4

Right click Surface15 and select New loads &
constraints → New fixed support

Step 5

Solve

Select any of the results below the Solution group in the outline tree.

Drag the slider on the timeline to display the results at
the various time steps. Select a node to display a
graph of its displacement.
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2.8 DC Circuit

The following circuit will be solved for the voltage drop across the resistances, and the currents.

Current flowing through the 40Ω and 50Ω resistors
is
12V/(40Ω+50Ω) = 0.13A

Current  flow  through  the  60Ω  resistor  is  
12V/60Ω = 0.2A

The  voltage  drop  across  the  40Ω  resistor  is
0.13A×40Ω = 5.3V 

Voltage drop across the 50Ω resistor is 

0.13A×50Ω = 6.7V

Voltage drop across the 60Ω resistor is 12V

Step 1

Right click, Edit. Select DC Current Flow.

Step 2

Click the Z arrowhead to view the XY plane parallel to the
screen. 

Click the New element tool and click in the graphics area to form
the following three line elements. For the 2nd and 3rd elements, be
careful to click on existing nodes so they are linked together.

Step 3

As each element has a different resistance, they need to be separate components.

Activate select elements
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Right click on the selected element and select Add elements to new 
component

Right click on the new component and 
select Assign new material. 
Electric tab
Resistor select
Resistance 40 Ω

Repeat this step for the second element.

Electric tab
Resistor select
Resistance 50 Ω

As there is only one element left in the Default under Components & Materials, right click to Assign 
a new material.

Electric tab
Resistor select
Resistance 60

Step 4

Activate Select nodes
 
Right  click  on  this  selected  node  then  select
Loads & constraints → New electric potential
type 0 in the text-box.
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Right  click  on  this  selected  node  then  select  Loads  &
constraints → New electric potential. Select units V then type
12 in the text-box.

A 12V voltage has now been applied to the circuit.

Step 5

Click to solve the model. 

Electric potential results are listed in the outline tree. To add current, right click Solution and choose 
New electric → current.

The results are listed in the outline tree below Solution. 

Select one of the field variables and then
click a node for a read-out of that value.

The sign of a current indicates its direction. If it is -ve, the current is
flowing in the direction in which you formed the element going from
the first node of that element to the second node. If the value is
+ve, current is flowing in the opposite direction from the second
node to the first. 

For the currents, read the element values instead of the node averaged value. Nodal averaging can be
misleading, for example the -0.2A in the 60Ω resistor averaged with the 0.1333A in the 40ohm resistor
gives a non-existent 0.03333A.
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2.9 Electrostatic Analysis of a Capacitor

The electric field in a simple two plate capacitor will be modeled. The plates are 0.005 m apart with air
in between, and a potential difference of 1.5V.

The expected electric field, E = potential difference / distance between plates 

E = 1.5 / 0.005 = 300 V/m

Step 1

Right click, Edit. Select Static 2D

Step 2

Click the Z arrowhead to view the XY plane parallel to the screen. 

Mesh tools → Create → Node... 
X 0
Y 0
Z 0

A red dot appears at the origin.

Add  more nodes  using  the following  coordinates,  all
with units of m.
(0.015,0,0)
(0.015,0.005,0)
(0,0.005,0)

Use the Fit to window to display the nodes
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Step 3

In this tutorial the area between the two plates of the capacitor will be defined using two node line
elements, and then the 2D automesher will then be used to fill the region with quadrilateral or triangle
elements.

Mesh tools → Create → Element... Select and click the four nodes to form the area
between the two plates. 

Step 4

Mesh tools → Automesh 2D...
Maximum element size 0.001 m
accept the rest of the defaults

Step 5

Right click,  Assign new material
Geometric tab
Thickness 1 m

Electric tab
Isotropic select
Relative permittivity 1
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Step 6

Activate Select faces

Drag to select the faces along the top edge.

The element faces will become selected. Although
they appear to be edges, in reality they are faces
normal  to  the  screen  because  of  the  thickness
dimension that is not displayed.

While the faces (edges) are selected,
right  click  on  Loads  &  Constraints
then  click  New  electric  potential.
Select V and type 1.5 in the text-box.

Drag to select the faces at the bottom.

While the edges (faces) are selected,
right  click  on  Loads  &  Constraints
then  click  New  electric  potential.
Accept the default 0 value.

Step 7

Click to solve the model. 

Some results are listed in the outline tree. Right click Solution and choose New electric → electric 
field. Then click the new electric field branch of the outline tree to display the field. It matches the 
expected value of 300 V/m.
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2.10 Acoustic Analysis of an Organ Pipe
We will predict the musical note produced by an 8 ft long 'open wood' organ pipe. An actual pipe would
be rectangular in section, but here we make only a 2D model. The pipe will be 120 mm wide with a 30
mm mouth at one end where air is blown in, and an opening at the other end for the air to exit. The
wood is 10 mm thick. 

In acoustic analysis the air within the pipe needs to be meshed and not the pipe itself. The mesh
needs to include a large volume of the air in the room outside the pipe which is connected to the
mouth and the open end.  This scheme allows Mecway to model leakages and openings.  We are
interested only in the resonant modes of the organ pipe, but Mecway will also predict resonances in
the air outside. An important part of this case study, therefore, is to show how some understanding of
the physics is required in order to interpret the results and identify the appropriate modes.

A rough calculation will be made for the expected frequency. 

An end correction factor must be added to the length of the pipe. This correction factor is equal to the
width of the pipe. So the effective length of the pipe is 2.4384 m + 0.12 m = 2.5584 m

When 1/2 a wavelength fits into the pipe it will be of wavelength λ = 2 × 2.5584 m = 5.1168 m

The speed of sound in air at 15°C is 340 m/s, so the expected frequency will be f=v/λ = 340/5.1168 =
66.45 Hz.

Step 1

Double click Analysis, then select Acoustic Resonance 2D
Number of modes 20 

To ascertain the fundamental pitch we need to examine the results for a number of pitches. We will
also look at harmonics.

Step 2

Click Quick square  to create a quad4 element.
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Click the Z arrowhead to orient the XY plane parallel to the screen.

Step 3

Drag to select the two right-most nodes then use Mesh tools → Node coordinates and change their
X coordinates:

X 10 m

Y (blank)

Z 0

Use Edit → Select nodes by formula and enter

0 < y

then click Apply and Close to select the two top-most nodes. Use Mesh tools → Node coordinates
again to change their Y coordinates:

X (blank)

Y 2 m

Z 0

Press Fit to window  so you can still see the whole mesh.

Step 4

Click a blank place in the graphics area to clear the selection.

Click Refine x2  three times.

Step 5

Change to Select elements mode  and select the elements shown then delete them by pressing the
del key.  To select  the  large regions,  drag the mouse.  Hold  the  ctrl key  to  add  elements  to  the
selection.
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Step 6

Use Mesh tools → Move/copy... and enter an X displacement of -2.5 m.

Press Fit to window  so you can still see the whole mesh.

Step 7

Here we'll set the length of the pipe and width of the mouth.

Change to Select nodes mode 

Select the 4 nodes shown then right click one of them
and choose  Node coordinates.  Specify  X as  8 ft and
press OK.

Select the 4 nodes shown then right click one of them
and choose  Node coordinates.  Specify  X as  -10 mm
and press OK.

Select the 2 nodes shown then right click one of them
and choose  Node coordinates.  Specify  X as  30 mm
and press OK.

Step 8

Here we'll set the pipe's width and wall thickness.

Select the 4 nodes shown then right click one of them
and choose  Node coordinates. Specify  Y as  620 mm
and press OK.

Select the 4 nodes shown then right click one of them
and choose Node coordinates. Specify  Y as  630 mm
and press OK.
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Select the 4 nodes shown then right click one of them
and choose  Node coordinates. Specify  Y as  490 mm
and press OK.

Step 9

Select these 8 room air nodes to the left of the pipe and
use Mesh tools → Scale... with an X factor of 0.5. Then
click  a  blank  space  in  the  graphics  area  to  clear  the
selection.

Step 10

Generate a finer mesh using Mesh tools → Automesh 2D...

Max. element size: 200 mm

Quad dominant: checked

Step 11

Right click the Default component and select Assign new material
Mechanical tab
Isotropic select
Speed of sound 340

Step 12

The mesh building is now complete so click to solve the model. 

The modal frequencies are listed in the outline tree below Solution. Click the nodes for a read-out of
the field variable there.

The subtlety in this case study is in interpreting the results. From the 20 calculated modes we want to
pick out the fundamental pitch of the pipe itself. Click through the various modes and observe that
most show red, yellow and blue patches for the room air elements.

The 4th mode at 64.59 Hz is different because the ‘room’ is almost at constant pressure (color). Zoom
in on the pipe and notice that the magnitude of the maximum pressure inside the pipe is much higher
than anywhere outside the pipe. This identifies mode 4 as the fundamental pitch of the organ pipe.
Half a wavelength fits inside the pipe. The frequency matches the hand calculated value very well.
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Similarly Mode 8 at 131 Hz has an almost constant pressure in the room and high, variable pressure
in the pipe. This is the first harmonic at twice the frequency of mode 4, sounding one octave higher. A
full wavelength fits inside the pipe. 
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2.11 Buckling of a Column

The eigenvalue buckling of a column with a fixed  end will be solved. The column has a length of
100mm, a square cross-section of 10mm and Young's modulus 200000 N/mm2 .

The critical load for a fixed end Euler column is π2EI/(4L2)

E = Young's modulus

I = moment of inertia

I = 104/12 = 833.33mm4

L = length

Critical load = π2 200000 × 833.33 / (4×1002)= 41123.19

Step 1

Right click, Edit. Select Buckling 2D Beam.
Number of modes 3
Shift point 1

Step 2

Mesh tools → Create → Node... 

X 0
Y 0
Z 0

The node appears as a red dot at the origin.

If you don't see the node, make sure you've activated the node select mode

Add another node using the following co-ordinates.
(0, 100 mm, 0)

Use the Fit to window  to display the nodes.
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Step 3

Mesh tools → Create → Element.. Select and click the two
nodes. 

Step 4

Right click, select Assign new material
Geometric tab
General section select
2nd moment of area about W 833.33 mm4

Cross sectional area 100 mm2

Mechanical tab
Isotropic select
Young's modulus 200000 MPa

Step 5

Mesh tools → Refine → x2 or four times. 

To see the mesh refinement switch to the node select mode

Step 6

Select this node then right click  and select New force. In

the Y box, select unit N and type -1.
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Step 7

Activate select nodes

Select the node at the bottom then change to face selection mode 

Now the bottom end face is selected.

Right click and select New fixed support

Step 8

Click to solve the model. 

The results are listed in the outline tree below Solution. 

Click the animation tool-button to view the buckling mode shape.

As the load used for the model was 1N, the load
at failure is 1  × 41123.27 = 41123.27 N, which
approximately  matches  the  hand  calculated
value of 41123.19.

The error in the last two digits can be reduced
by increasing the value of Shift point in step 1
from 1 to 10000. This higher value is chosen to
be slightly less than the lowest buckling factor.

That concludes our overview of the types of analysis which Mecway can carry out. Bear in mind that 
mechanical analysis can generally be done using orthotropic materials such as wood or carbon fiber 
composites, as well as the more familiar isotropic materials.
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3Chapter 3
Operations

3.1 Extrude
Step 1

Open  ExtrudeTutorial.liml from  the  tutorials  folder  where
Mecway has been installed.

Step 2

Activate Select faces 

Drag  the  mouse  over  the  entire  mesh  so  that  it  becomes
selected.

Step 3

Mesh tools → Extrude...

Thickness 5 m

Number of subdivisions 3

Direction +Z

54



Step 4

The  extrusion  step  turned  off  Select  faces so
reactivate it again.

Select the faces at the bottom.

Mesh tools → Extrude...

Thickness 5 m

Number of subdivisions 3

Direction +Normal

3.2 Loft
Step 1

Open  LoftTutorial.liml from the tutorials folder where Mecway has
been installed. 

Step 2

Display node and element numbers. 

Note down the node numbers of any two corresponding nodes on
each profile. In this example the bottom corner node numbers are 12
and 135.
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Step 3

Activate Select faces. 

Drag to select the profile of node number 135.

Step 4

Mesh tools → Loft...

Number of subdivisions 4

A node in selected faces 135

The corresponding node 12

3.3 Refine Local 2D

Step 1

Open RefineLocal2dTutorial.liml from the tutorials folder where Mecway has been installed. 

Step 2

Drag the mouse to select the nodes shown below. Don't worry if you selected a few extra nodes, this is
only an illustration.
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Step 3

Mesh tools → Refine → x3 (1D/2D elements only) 

3.4 Mirror Symmetry
Step 1

When the geometry and loads are symmetric, you can
model just the part on one side of the symmetry plane(s).
This  revolved  shell  can  be  modeled  as  only  one
quadrant.  Open  MirrorSymmetryTutorial.liml from the
tutorials folder where Mecway has been installed. 
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Step 2

The  quarter  segment's  vertical  plane  of  symmetry  is  the  XY  plane  and  its
horizontal plane of symmetry is the ZX plane. Its axis of revolution is the X-axis.

Activate Select nodes  

Select the nodes lying in the vertical plane of symmetry.  Constraints need to be
applied to keep these nodes from moving out of the XY plane, while allowing them
the freedom to move within the XY plane. 

Right click  the selected nodes

Loads & constraints → New displacement and select the Z option.

Since shell nodes have rotational degrees of freedom, the nodes in
the XY plane must  be prevented from rotating  about  the X and Y
axes.

Right click on the selected nodes again

Loads & constraints → New node rotation and select the X option.

Repeat for the Y axis.

Step 3

While still  in  Select nodes   mode, select  the nodes lying in  the horizontal
plane of  symmetry.  Constraints  need to be applied to keep these nodes from
moving out of the ZX plane or rotating about any axis lying in that plane. 

Right click on the selected nodes

Loads & constraints → New displacement and select the Y option.

Right click on the selected nodes again

Loads & constraints → New node rotation and select the  X
option.

Repeat for the Z axis.

3.5 Cyclic Symmetry

Instead of modeling the entire wheel using solid elements, only
one segment will be modeled using cyclic symmetry.
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Step 1

Open CyclicSymmetryTutorial.liml from the tutorials folder where Mecway has
been installed. 

Step 2

Activate Select nodes  

Hold the Ctrl key down and select these 12 nodes with the
mouse. 

Right click on one of the selected nodes and select Add nodes to new named selection.

Click a blank part of the graphics area to deselect the nodes 

Hold the Ctrl key down and select these nodes with the
mouse. 

Right click on one of the selected nodes and select Add nodes to new named selection.

Step 3

Right click Loads & Constraints and select New cyclic symmetry. 

Master nodes Unnamed
Slave nodes Unnamed(2)
Axis of symmetry Y
Number of segments 12

Step 4
Click Solve  then click on some of the modes to see that the solution has expanded the model to a
complete ring and that it includes mode shapes which are not cyclically symmetric as well as those
that are.

3.6 CAD Work-flow
Step 1

Use File → Open or right click  and select Import STEP file

Open the file CadWorkflowTutorial.stp from the tutorials folder where Mecway has been installed.

Drag anywhere in  the graphics area using the middle mouse button to rotate it  so the faces are
distinct.
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Step 2

Right click the file name and select Generate Mesh

Step 3

Right  click  the  component  and  select  Assign  new
material.  In the  Mechanical tab select  Isotropic then
type 200E09 in the text box for Young's modulus

Step 4

Click the file name to return to the geometry view then right  click  a surface and select Loads &
constraints then New fixed support. 

Step 5

Use  the  middle  mouse  button  to  rotate  the
model,  then right click the inclined surface and
select  Loads  &  constraints, then  select
Pressure. Type 1000 to apply a pressure to the
selected surface.
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Step 6

Click Components & Materials in the outline tree to switch to the
mesh view. Click Show element surfaces  to give a clearer view.

Step 7

Click  Solve  then  view  the
results

3.7 Local Refinement with CAD Models
Step 1

Open RefineLocal3dTutorial.stp from the tutorials folder where Mecway has been installed.

Step 2

Right click the filename and select Generate mesh

Step 3

Activate Select nodes 

Right click a node and choose New point refinement then press OK to accept the default values.
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Step 4

Right click the filename and select Generate mesh 

Multiple local refinements can be applied following the same procedure. 

3.8 Mixed Materials
Step 1

Open a new instance of Mecway.

Step 2

Click Quick cube 

Step 3

Click Refine 

Step 4

Right click the Default component in the outline tree and
select  Assign  new  material.  Choose  Isotropic and
enter:

Young's modulus 200e9

Poisson's ratio 0.3

Click OK

Step 5

Change  to  Select  elements mode   and
select  two of  the 8 elements.  Hold the  Ctrl key while
clicking on each element.
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Step 6

Right  click  one  of  the  selected  elements  and  choose
Add elements to new component. The newly created
Material(2) is a duplicate of the first material but you can
change its properties independently.

Step 7

Click on an empty space in the graphics area to clear the
selection then click Show element surfaces  . Notice
that each material's component has a different color so
you can easily distinguish them.

3.9 Mixed Materials with CAD Assemblies
This tutorial shows you how to make a model from multiple parts which may have different materials.
To use your own models, you must first export each part from your CAD software as a separate STEP
file.

Step 1

Use File → Import to import  plate.step and cylinder.step
from the tutorials folder where Mecway has been installed.
For convenience, you can open both files at the same time
by holding Ctrl while selecting them.

Ste  p 2  

Right  click  the  cylindrical  surface,  then  click  Loads  &
constraints → New bonded contact. Set Master faces to
<1 selected geometry surface> and click OK.
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Step 3

Use the middle mouse button to rotate the geometry and find the thin surface of the plate adjacent to
the cylinder.  Click this surface to select it. Right click  bonded contact in the outline tree and click
Edit. Set Slave faces to <1 selected geometry surface> and click OK.

Step 4

Right click Geometry in the outline tree and click Generate all meshes.

Step 5

Click  the  Geometry branch  of  the  outline
tree  to  return  to  the  geometry  view.  Right
click the circular end of the cylinder and click
Loads  &  constraints  →  New  fixed
support. Click OK.

Step 6

Right click the large surface of the plate and click
Loads & constraints → New force. Specify a Y
component of -100 lbf. Click OK.

Step 7

Right  click  the  plate  <###  elements  linked>
component in the outline tree, click  Assign new
material and specify the following data:

Isotropic

Young's modulus: 70 GPa

Poisson's ratio: 0.35

Press OK and repeat for the cylinder <### elements linked> component and the following material
data:

Isotropic

Young's modulus: 210 GPa

Poisson's ratio: 0.3

Step 8
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Click solve .

Step 9

Click the Displacement Magnitude field variable then the Animate button  to show the deformation
caused by the load.

3.10 Constraint Equations
Step 1

Open CoupledTutorial.liml from the tutorials folder where
Mecway has been installed.

Step 2

Activate Select nodes 

Step 3

Right click Loads & Constraints and select New constraint equation

Click New term and specify:
Coefficient 1
DOF Displacement in X
Node 201
Click OK
Click New term again and specify:

65



Coefficient -1
DOF Displacement in X
Node 36
Click OK

The constraint equation should now read

1 ux201 - 1 ux36 = 0

Click OK to save it, then create two more constraint equations in the same way – one with 
Displacement in Y and one with Displacement in Z.

Step 4

Right click this node and select Loads & constraints → New force 
Apply to <Selected nodes>
X 100

Step 5

Right click , Solve 

The two nodes have the same displacement as if they are connected by a rigid, non-rotating bar.

3.11 Advanced Manual Meshing
Step 1

Identify  the  most  difficult
features and model them
before  the  easier
features. 

In  this  model  the  side
holes  that  intersect  with
the through hole  are  the
most  difficult,  so  this  will
be modeled first.
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Step 2

Mesh tools → Create → Node...

Next node's coordinates:
X 12
Y 0
Z 0

Click the Add button

Change Y to 100 click Add
change X to -12 click Add
change Y to 0 click Add
click Close

Click the Z arrowhead to view the model parallel to the screen.

View → Fit to window

Mesh tools → Create → Element...

Create a line2 element by clicking on the bottom-right node, then the top-right node.
Repeat this to create a total of 4 elements as shown.

For now it has been modeled to a width of 24 but later it will be stretched to the
actual width of  50.  This  was necessary because the left  and right  faces will  be
rotated in a later step and we didn't want them to penetrate other elements inside the mesh.

Step 3

Mesh tools → Create → Curve generator...

 

D1 16
D2 16

Click OK to exit the ellipse dialog but don't exit the curve generator dialog just yet. 

Change the  Y = 8*sin(p)  into Y= 25 +8*sin(p). This will move the circle up by 25 where
we would like it to be positioned. Change the Number of elements to 12. Click OK to
exit the curve generator dialog.
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Step 4

Mesh tools → Create → Curve generator...

 

D1 16
D2 16

Click OK to exit the ellipse dialog but don't exit the curve generator dialog. 

Change the  Y = 8*sin(p)  into Y= 75 +8*sin(p), this will move the circle up by 75 where
we would like it to be positioned. Change the Number of elements to 12. Click OK to
exit the curve generator dialog.

Step 5

You will be meshing this with the 2D automesher. But before doing so, you have to delete duplicate
nodes created during the meshing operations using  Mesh tools → Merge nearby nodes  with a
Distance tolerance of 0.001. Note the change in node numbers in the status bar after this command
has been run.

Mesh tools → Automesh 2D...
Maximum element size 8

The automesher will briefly run in a separate window and
then close.
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Step 6

Select these nodes. Right click on the selected nodes and choose Node coordinates and 
enter 25 for the X coordinate. 

Select these nodes. Right click on the selected nodes and choose Node coordinates and
enter -25 for the X coordinate. 

The hexagon edge length has now been restored to 50.  It  had to be
widened because those two faces will be rotated by 30 degrees later.

Step 7

Activate select nodes 

Select the following nodes and press the delete key. This is to prepare for
the slot that will be done at a later step.
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Select these nodes then right click on one of the selected nodes and choose Node coordinates and 
enter 93 for the Y coordinate.

Likewise, select these nodes then right click on one of the selected nodes and choose 
Node coordinates and enter 7 for the Y coordinate.

Select these nodes. Hold the Ctrl key while selecting them. Right click on one of the 
selected nodes and choose Node coordinates and enter -5 for the X coordinate.

Select these nodes. Hold the Ctrl key while selecting them. Right click
on one of the selected nodes and choose Node coordinates and enter
5 for the X coordinate.

The mesh is now prepared for the 10×7 slot

Step 8
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Mesh tools → Create → Element...
quad4 shell

Click the nodes to form quadrilaterals.

Step 9

Activate select faces

Select the entire mesh. 

Mesh tools → Extrude...
Direction +Z
Thickness 23.3
Number of subdivisions 3

Step 10

Activate select nodes
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Select the entire mesh, Mesh tools → Move/copy...
  Z 20
 

Step 11

Activate select nodes

We will be using this co-ordinate information to rotate the right hand face.

Click the Z arrowhead to view the model parallel to the screen.

Select all the nodes on this face.
Mesh tools → Rotate/copy...
Axis direction Y

X 25
Y 0
Z 43.3

Angle 30°

Make sure that the copy check-box is not selected.

Step 12
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We will be using this co-ordinate information to rotate the left hand face.

Select all the nodes on this face.
Mesh tools → Rotate/copy...
Axis direction Y

X -25
Y 0
Z 43.3

Angle -30°

Step 13

Click the Y arrowhead to view the model parallel to the screen.

Activate select nodes 

Select these nodes. Mesh tools → Fit to curved surface...

Cylinder select
Center
X 0
Y 0
Z 0
Radius 20
Axis
Y select
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Step 14

Activate select nodes

Select the entire model. 
Mesh tools → Rotate/copy...
Axis direction Y
X 0
Y 0
Z 0
Angle 60°
Copy selected

With the newly created elements selected, repeat the Mesh tools → 
Rotate/copy... with the same parameters and just click Apply.

Once again with the newly created elements that are selected, repeat the 
Mesh tools → Rotate/copy...
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Do it again with the newly created elements that are selected. Repeat the Mesh tools → 
Rotate/copy...

Once more for the final time. 

That completes the hexagonal shape. Now use the Mesh tools → Merge nearby nodes with a 
Distance tolerance of 0.01 to eliminate duplicate nodes created during the meshing operations. Note 
the change in node numbers in the status bar.

Step 15

Activate select nodes 
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Click the Z arrowhead to view the model parallel to the screen.

Edit → Circle selection and drag to select the 
nodes of the holes. Hold the Ctrl key to add to the 
node selection set. Also hold the Shift key to keep a
node from moving if you happen to click on it.

Then press the 
delete key.

Step 16

Activate select elements

Select the elements where the slots are to be and press the delete 
key.
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Step 17

Activate select elements

Similarly, rotate the model and select the elements where the slots are 
to be and press the delete key.

Step 18

As this is a coarse mesh use the Mesh tools → Refine → x2 to refine the mesh further.

3.12 Assembly  with Contact
This tutorial is to help get a static solution for an assembly of parts 
that are held in place by contact with each other. It assumes you're 
familiar with general use of Mecway and contact.

All parts of an assembly must be initially in static equilibrium 
otherwise the solver won't converge. That means all loaded 
parts must have constraints to provide reaction forces. Contact is 
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not reliable as an initial constraint and can leave some parts unconstrained or otherwise prevent the 
first time step from converging.

We will look at a model of a three-point bending test that fails and try various adjustments until it 
solves.

Step 1

Open AssemblyWithContact.liml from the tutorials folder where Mecway has been installed.

Step 2

Solving the Naive configuration. The solver fails with the message

*ERROR: too many cutbacks best solution and residuals are in the frd file

Step 3

Make sure the problem is caused by rigid body motion and that the contact is otherwise working 
correctly. We do this by adding a Fixed support to each free part. Try this by solving the 
Fixed_support configuration.
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It solves quickly and the sample bends into the expected shape. The deformed shape looks strange at
first because it’s exaggerated due to the high deformation scale factor and low displacement 
magnitude. This is not the correct solution because of the artificial fixed support but it shows that the 
failure was likely due to lack of constraints.

Step   4  

A failure at the first step is physically reasonable because the contacting surfaces are frictionless so 
the sample is free to slide out of place. We correct this by adding friction to constrain it. Try this by 
solving the Friction configuration.

Unfortunately, friction is not sufficient because the sample and/or loading pin are not being properly 
constrained by the contacts. You can to see this in the non-converged solution. If displacements are 
too high, set a suitable deformation scale factor in Solution → Deformed view settings.
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Step   5  

We next add Elastic support to the sample and loading pin to weakly constrain them. The elastic 
support's stiffness should be low enough that it won't significantly interfere with the model but high 
enough to prevent extreme displacements. Try this by solving the Elastic_support configuration. It still 
fails.

Step   6  

A final way to help it converge is by starting with a smaller initial force. This is easy to accomplish 
without affecting the final force by ramping it quadratically (Fy = -1000 × t2) instead of linearly (Fy = -
1000 × t). Try this by solving the Quadratic_ramp configuration.

Now it solves successfully. Notice that the displacement is symmetric despite the unsymmetrical 
locations of the elastic supports. That indicates they are weak enough not to have an obvious effect on
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the solution. To measure this more accurately we should check that the external forces at the elastic 
supports are negligible. Unfortunately, external force is not available with elastic support so you would 
need to replace it with fixed support connected to the model through elements with a low stiffness 
material.

That concludes this Tutorials guide. Hopefully you will now be quite familiar with Mecway, and have 
confidence to modify the examples above and build your own models from scratch. For more detailed 
information and samples, see the companion Manual.
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